FAQ
- DeviceXPlorer
[Ver.7] Communication between processes of the DeviceXPlorer OPC Server is not available
2026.02.04
Overview
The DeviceXPlorer OPC Server Ver.7 consists of three processes: the configuration tool, the runtime, and the license manager.
In some cases, errors may occur when communication between these processes is blocked.
Symptoms
The following issues may occur at startup:
- An error stating “Failed to write settings to the runtime” is displayed.
- Messages such as “The license key is not installed” are displayed, and license authentication fails.
- No logs are displayed in the message view.
Cause
The issue may be caused by the proxy settings.
Solution
If proxy settings are enabled, please try one of the following:
- In the manual proxy setup, enable the option “Do not use a proxy server for local addresses.”
- Remove the proxy settings from the environment variables.
- Configure port exclusions in the proxy environment variables (add “NO_PROXY” and set it to “localhost”).

